A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 15:14 AEDT
Identified
We’ve identified an issue affecting American Express transactions processed on terminals. Merchants may experience declines when accepting American Express cards on Verifone T650p, Ingenico Move5000, and PAX A920, A910s, and A80 devices.
Our team is actively investigating the issue with the card scheme. In the meantime, we recommend advising customers to use alternative cards for their transactions.
Posted Oct 31, 2025 - 10:46 AEDT
This incident affected: Ingenico Move5000 terminal, Quest QT720 terminal, PAX A920 terminal, and PAX A910s terminal.