Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 28, 2025 - 19:00 AEDT
Scheduled
A scheduled maintenance will be conducted across all online payments channels between 7: 00pm – 8:30pm AEDT on 28 October 2025. Payment services are expected to remain unaffected; however, merchants may experience service degradation when processing online payments during the maintenance period.
For more information, please submit a request via the Help Centre.
Posted Oct 22, 2025 - 14:34 AEDT
This scheduled maintenance affected: Payment Links, Online Checkout, and Hosted Payments Page.