September monthly statement delay

Incident Report for Vostropay

Resolved

The issue is now resolved, merchants can now view the September Monthly Statement on the VostroPay Merchant Portal (https://merchant.vostropay.com.au/login).

We, once again, apologise for the inconvenience caused and thank you for your patience as we worked towards resolving the issue.
Posted Oct 18, 2025 - 07:58 AEDT

Update

Our team is still working closely with our 3rd-party partner to resolve the issue as soon as possible. We apologise for the inconvenience that was caused.
Posted Oct 15, 2025 - 14:50 AEDT

Identified

We’re currently experiencing a delay in the release of the September monthly statement due to a third party outage. Our team is working closely with our provider to resolve the issue and publish the statement as soon as possible.

Update will be provided once a confirmed release date is available. We apologise for the inconvenience this caused and thank you for your patience as we work towards resolving the issue.
Posted Oct 10, 2025 - 14:08 AEDT
This incident affected: VostroPay Merchant Portal and VostroPay Merchant & Partner Portal.