Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 13, 2025 - 00:00 AEST
Update
The VostroPay Merchant Portal (https://merchant.vostropay.com.au/login) will undergo a maintenance window from 2:30pm to 6:00pm AEST, during which the platform will be unavailable.
After the maintenance is complete, the changes outlined in the previous status will be reflected. Please also note that the funding remitter name will be updated to "Nuvei MS" as part of the maintenance.
Posted Sep 11, 2025 - 11:13 AEST
Scheduled
Due to a system update, AMEX data will no longer be supported and visible on the VostroPay Merchant Portal (https://merchant.vostropay.com.au/login) for selected merchants with an AMEX ID from Saturday, 13 September 2025 onwards.
Impacted merchants will be communicated with affected MIDs directly via email.