We have pushed a software update, and the issue should now be resolved. We will continue to monitor the issue and provide information if there's any update.
Posted Oct 27, 2025 - 09:18 AEDT
Identified
An issue has been identified impacting the acceptance of certain cards on PAX terminals, including PAX A920 and PAX A910s.
Merchants may encounter a “Card not allowed” and “Decline” error when processing specific card types. The issue currently appears to affect certain cards issued by the following institutions, though additional issuers may also be impacted:
NAB, American Express, ING, Revolut, St. George, Macquarie Bank, and Greater Bank.
The same error may appear if the customer is paying with the certain cards issued by the above institutions via digital wallets, including ApplePay, SamsungPay and GooglePay.
We recommend that merchants request customers to use an alternative card while we work with our external partner to resolve the issue. This remains our top priority, and we sincerely apologise for the inconvenience this has caused.
Posted Oct 17, 2025 - 11:40 AEDT
This incident affected: PAX A920 terminal and PAX A910s terminal.