We would like to let you know that the September 2025 rebates are now available on the VostroPay Merchant Portal.
We apologise for the delay, and we thank you for your patience as we work towards resolving the issue.
Posted Oct 24, 2025 - 11:17 AEDT
Identified
Due to a third-party outage, we are currently experiencing a delay in Partner rebates calculation on the VostroPay Merchant Portal (https://merchant.vostropay.com.au/).
We apologise for the delay, and our team is working closely with our external partner to resolve the issue. If you require more information regarding the issue, please submit a request via our Help Centre.
Posted Oct 20, 2025 - 11:09 AEDT
This incident affected: VostroPay Merchant Portal.